LUG Castegnato - Linux Users Group Castegnato / collegamento stampante lexmark interpret s405

LUG Castegnato - Linux Users Group Castegnato

Linux User Group Castegnato - BS

Non hai eseguito l'accesso.

#1 10-01-2012 23:43:00

antoniovia
Nuovo Utente
Registrato: 10-01-2012
Messaggi: 5

collegamento stampante lexmark interpret s405

Buonasera,
mi sono appena iscritto dopo aver da poco installato ubuntu 11.4
Tra le prime operazioni volevo collegare la mia stampante lexmark interpret s405 ma mi succede un'anomailia dopo aver seguito i seguenti passaggi suggeriti dal supporto di linux:
1) la stampante collegata via cavo usb viene riconosciuta come hw nel centro di controllo
2) si avvia la ricerca dei driver;
3) dopo diversi minuti non viene trovato il driver specifico per questa stampante e mi viene proposto di selezionare un driver generico;
4) una volta selezionato il driver generico e dopo aver lanciato la stampa di prova si verifica il seguente errore:
"errore del server cups"
client - error - document -format - not supported
5) la stampante comunque è visibile ma nelle proprietà non risulta attiva

Qualcuno mi puo' aiutare?
Grazie infinite

Non in linea

 

#2 11-01-2012 15:03:01

gattosilvestro
Moderator
Registrato: 20-05-2008
Messaggi: 442

Re: collegamento stampante lexmark interpret s405

Ciao antoniovia, linux è supportato ufficialmente dalla Lexmark Interpret S405. Devi però scaricare i driver dal sito lexmark ed installarli manualmente. Vai a questo link, clicca su Spec e poi su VIEW MORE SPEC per vedere i sistemi operativi supportati, tra cui c'è anche linux.

Per installare i driver segui questa procedura:

1. Prima di tutto devi installare il Java Runtime Environment ed xsane, che è necessario per la gestione dello scanner. Da terminale da il seguente comando:

Codice:

sudo apt-get update && sudo apt-get install xsane openjdk-6-jre

2. Crea una cartella dal nome lexmark nella tua home. Da terminale:

Codice:

mkdir ~/lexmark

3. Vai a questo link e clicca su More >> per trovare i driver per Ubuntu. Se utilizzi la versione a 32 bit clicca sul link "Printer driver (without JRE) for 32-bit Linux distributions with Debian-based packaging", se invece utilizzi la versione a 64 bit clicca sul link "Printer driver (without JRE) for 64-bit Linux distributions with Debian-based packaging" (le versioni di Ubuntu supportate sono  Ubuntu 9.04, Ubuntu 9.10, Ubuntu 10.04, Ubuntu 10.10, Debian 6.0, Linux Mint 10 , Ubuntu 11.04 ). Quindi clicca su DOWNLOAD e scarica il file nella cartella lexmark che hai creato in precedenza.

4. Da terminale da i seguenti comandi:

Codice:

cd ~/lexmark
tar xzvf lexmark-inkjet-legacy-1.0-1.i386.deb.sh.tar.gz 
sudo ./lexmark-inkjet-legacy-1.0-1.i386.deb.sh

5. Segui la procedura di installazione guidata. Insieme ai driver verrà installata l'applicazione "Lexmark Printer ToolBox", per la configurazione della stampante.
Secondo le istruzioni riportate sul sito Lexmark dovrebbe essere installato anche il programma "Wireless Setup Utility", che permette di configurare il collegamento wireless alla stampante. Ho provato ad installare il file .deb.sh sul mio pc, ma nelle applicazioni ho trovato solo "Lexmark Printer ToolBox". Casomai se hai il wireless facci sapere se la stampante funziona anche con quello.

P.S. Come regola del forum, bisognerebbe presentarsi nella sezione Presentazioni smile

Ultima modifica di gattosilvestro (17-01-2012 12:47:55)


ASUS P5K-VM | INTEL CORE 2 DUO E6300 | MAXTOR SMT3160812AS, MAXTOR3320820AS | 2 x CORSAIR VS1GB667D2 | SONY AWG170AB2 DVD+-RW DL

Non in linea

 

#3 17-01-2012 00:17:56

antoniovia
Nuovo Utente
Registrato: 10-01-2012
Messaggi: 5

Re: collegamento stampante lexmark interpret s405

Ciao gattosilvestro, innanzitutto grazie per la tempestiva risposta e scusa se mi faccio sentire solo oggi.
Ho seguito le tue istruzioni ed è andato tutto bene fino all'ultimo passaggio, il n.5 dove durante la procedura di installazione viene visualizzato il seguente errore:
"The installer has detected that the operating system does not have a compatible JRE installed. Please download Lexmark driver with JRE. (lexmark-inkjet-legacy-wJRE-2.0.1)"

Ho provato a cercare wJRE-2.0.1 sul sito lexmark ma non l'ho trovato.
Come posso fare?

Ciao e grazie ancora in anticipo

Non in linea

 

#4 17-01-2012 12:46:50

gattosilvestro
Moderator
Registrato: 20-05-2008
Messaggi: 442

Re: collegamento stampante lexmark interpret s405

Vai nell'Ubuntu Software Center, cerca "ubuntu-restricted-extras", ed installalo. Oppure da terminale da il seguente comando:

Codice:

gatto@tux:~$ sudo apt-get update && sudo apt-get install ubuntu-restricted-extras

Durante l'installazione ti verrà chiesto di accettare alcune licenze.

Con questo pacchetto vengono installati automaticamente numerosi altri pacchetti, che contengono a loro volta i codec per i file MP3 ed altri formati audio (GStreamer plugins), i font di Microsoft, Java runtime environment, Flash plugin, LAME (per creare file audio compressi), librerie per riprodurre i DVD.
È un pacchetto molto utile che io installo di solito appena dopo aver completato l'installazione di Ubuntu. Visto che sul mio pc era già presente, non mi ero accorto che era necessario anche il JRE (Java Runtime Environment).

Se vuoi soltanto il JRE devi installare il pacchetto "openjdk-6-jre" (ho corretto il mio primo post, se dovesse servire a qualcun altro). Ti consiglio comunque di installare "ubuntu-restricted-extras".


ASUS P5K-VM | INTEL CORE 2 DUO E6300 | MAXTOR SMT3160812AS, MAXTOR3320820AS | 2 x CORSAIR VS1GB667D2 | SONY AWG170AB2 DVD+-RW DL

Non in linea

 

#5 18-01-2012 11:10:29

antoniovia
Nuovo Utente
Registrato: 10-01-2012
Messaggi: 5

Re: collegamento stampante lexmark interpret s405

Ciao gattosilvestro, volevo segnalarti che grazie alle tue ultime istruzioni sono riuscito ad attivare la stampante. Ti farò sapere anche per lo scanner, non penso che ci siano problemi, solo che ieri era notte fonda....proverò in questi giorni appena riesco a trovare un po' di tempo..
Grazie ancora per la collaborazione

Non in linea

 

#6 03-03-2012 23:00:55

antoniovia
Nuovo Utente
Registrato: 10-01-2012
Messaggi: 5

Re: collegamento stampante lexmark interpret s405

Ciao, ho fatto l'aggiornamento alla versione 11.10 e purtroppo non riesco piu' ad utilizzare la stampante che non viene proprio riconosciuta.
Ho provato a ripetere la procedura sopra indicata utilizzando i nuovi driver che ho trovato sul sito ma l'installazione non si completa perchè vengono trovate due componenti già installate e che sono da rimuovere solo che non so come fare:
- lexmark-inkjet-legacy
- lexmark-wsu-legacy

Potete per favore aiutarmi ancora?

Grazie

Non in linea

 

Footer forum

Powered by PunBB
© Copyright 2002–2008 PunBB