LUG Castegnato - Linux Users Group Castegnato / Errori durante l'aggiornamento

LUG Castegnato - Linux Users Group Castegnato

Linux User Group Castegnato - BS

Non hai eseguito l'accesso.

#1 07-12-2009 19:50:29

diegotedo
Utente
da: Brescia
Registrato: 08-07-2008
Messaggi: 146

Errori durante l'aggiornamento

Ciao a tutti, recentemente  nell'installare gli aggiornamenti di Ubuntu 9.10, mi ritorna il seguente errore

Codice:

E: linux-image-2.6.31-15-generic-pae: il sottoprocesso vecchio script di post-installation ha restituito lo stato di errore 127 
E: linux-image-2.6.31-16-generic-pae: il sottoprocesso vecchio script di post-installation ha restituito lo stato di errore 127 
E: linux-image-generic-pae: problemi con le dipendenze - lasciato non configurato 
E: linux-generic-pae: problemi con le dipendenze - lasciato non configurato

In pratica è già la seconda volta che mi capita, in quanto il sistema cerca di aggiornarlo ogni volta che sono disponibili degli aggiornamenti....
Qualcuno sa dirmi cosa significhi esattamente questo tipo di errore e se possibile risolverlo?

Grazie, ciao a tutti wink

Ultima modifica di diegotedo (07-12-2009 19:51:34)


-RUNNING FREE-

Non in linea

 

#2 10-12-2009 11:26:14

gattosilvestro
Moderator
Registrato: 20-05-2008
Messaggi: 442

Re: Errori durante l'aggiornamento

L'errore significa che ci sono dei problemi nell'aggiornamento del kernel.
Posta il risultato del comando "uname -r", che permette di vedere che versione di kernel stai usando.

Per capire qualche cosa di più sulle cause del problema da il comando "sudo apt-get update" e quindi posta il risultato del comando:

Codice:

sudo apt-get install -V linux-image-2.6.31-15-generic-pae

ASUS P5K-VM | INTEL CORE 2 DUO E6300 | MAXTOR SMT3160812AS, MAXTOR3320820AS | 2 x CORSAIR VS1GB667D2 | SONY AWG170AB2 DVD+-RW DL

Non in linea

 

#3 13-12-2009 20:13:34

diegotedo
Utente
da: Brescia
Registrato: 08-07-2008
Messaggi: 146

Re: Errori durante l'aggiornamento

Ecco il risultato:

Codice:

diego@diego-desktop:~$ sudo apt-get install -V linux-image-2.6.31-15-generic-pae[sudo] password for diego: 
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
linux-image-2.6.31-15-generic-pae è già alla versione più recente.
I seguenti pacchetti sono stati installati automaticamente e non sono più richiesti:
   linux-headers-2.6.31-14-generic-pae (2.6.31-14.48)
   linux-headers-2.6.31-14 (2.6.31-14.48)
Usare "apt-get autoremove" per rimuoverli.
0 aggiornati, 0 installati, 0 da rimuovere e 0 non aggiornati.
5 non completamente installati o rimossi.
Dopo quest'operazione, verranno occupati 0B di spazio su disco.
Configurazione di linux-image-2.6.31-15-generic-pae (2.6.31-15.50)...
Running depmod.
update-initramfs: Generating /boot/initrd.img-2.6.31-15-generic-pae
Running postinst hook script /usr/sbin/update-grub.
/etc/default/grub: 11: GRUB_WINDOWS: not found
User postinst hook script [/usr/sbin/update-grub] exited with value 127
dpkg: errore nell'elaborare linux-image-2.6.31-15-generic-pae (--configure):
 il sottoprocesso vecchio script di post-installation ha restituito lo stato di errore 127
Configurazione di linux-image-2.6.31-16-generic-pae (2.6.31-16.52)...
Running depmod.
update-initramfs: Generating /boot/initrd.img-2.6.31-16-generic-pae
Running postinst hook script /usr/sbin/update-grub.
/etc/default/grub: 11: GRUB_WINDOWS: not found
User postinst hook script [/usr/sbin/update-grub] exited with value 127
dpkg: errore nell'elaborare linux-image-2.6.31-16-generic-pae (--configure):
 il sottoprocesso vecchio script di post-installation ha restituito lo stato di errore 127
dpkg: problemi con le dipendenze impediscono la configurazione di linux-image-generic-pae:
 linux-image-generic-pae dipende da linux-image-2.6.31-16-generic-pae; comunque:
  Il pacchetto linux-image-2.6.31-16-generic-pae non è ancora configurato.
dpkg: errore nell'elaborare linux-image-generic-pae (--configure):
 problemi con le dipendenze - lasciato non configurato
dpkg: problemi con le dipendenze impediscono la configurazione di linux-generic-pae:
 linux-generic-pae dipende da linux-image-generic-pae (= 2.6.31.16.29); comunque:
  Il pacchetto linux-image-generic-pae non è ancora configurato.
dpkg: errore nell'elaborare linux-generic-pae (--configure):
 problemi con le dipendenze - lasciato non configurato
ConfNon è stata scritta alcuna segnalazione apport poiché il messaggio di errore indica che è un errore da un fallimento precedente.
                                                    Non è stata scritta alcuna segnalazione apport poiché è stato già raggiunto il valore MaxReport
                                                                   igurazione di grub-pc (1.97~beta4-1ubuntu4.1)...
/etc/default/grub: 11: GRUB_WINDOWS: not found
dpkg: errore nell'elaborare grub-pc (--configure):
 il sottoprocesso vecchio script di post-installation ha restituito lo stato di errore 127
Non è stata scritta alcuna segnalazione apport poiché è stato già raggiunto il valore MaxReport
               Si sono verificati degli errori nell'elaborazione:
 linux-image-2.6.31-15-generic-pae
 linux-image-2.6.31-16-generic-pae
 linux-image-generic-pae
 linux-generic-pae
 grub-pc
E: Sub-process /usr/bin/dpkg returned an error code

-RUNNING FREE-

Non in linea

 

#4 06-01-2010 18:42:29

djtwenty
Utente
Registrato: 09-10-2008
Messaggi: 19

Re: Errori durante l'aggiornamento

Ciao,
direi che l'errore nelle dipendenze dipende dal fatto che non trova in /etc/default/grub il pacchetto grub-pc.
Usi grub come bootloader? prova a ricaricarlo eventualmente. (fatti sempre un bel backup della configurazione per sicurezza)

djtwenty

Non in linea

 

Footer forum

Powered by PunBB
© Copyright 2002–2008 PunBB