LUG Castegnato - Linux Users Group Castegnato / Problemi con effetti visivi

LUG Castegnato - Linux Users Group Castegnato

Linux User Group Castegnato - BS

Non hai eseguito l'accesso.

#1 03-05-2009 18:38:01

Threepwood
Utente
Registrato: 01-07-2008
Messaggi: 44

Problemi con effetti visivi

Ciao a tutti,
ho installato la distribuzione 9.04 una favola va tutto, stampante , usb2, giochi ecc ; però ho un problemino.
Quando attivo gli effetti visivi quindi clicco su sistema, preferenze , aspetto, effetti visivi, aggiuntivi non mi funziona il click del mouse.
Mi spiego meglio quando li attivo viene visualizzata una finestra con scritto mantieni le impostazioni o ritorna al settaggio precedente, quest'ultimo è di colore arancio se sposto il mouse il pulsante si attiva , visivamente si vede premuto ma non provoca nessun effetto.
Questa cosa avviene solo con i pulsanti all'interno delle finestre mentre per quelli in alto a destra e il chiudi funziona.
Ho provato a cambiare il driver della scheda video ma il problema persiste , voi cosa ne pensate. (driver provati versione 173 e 180)
smile smile smile smile

Non in linea

 

#2 03-05-2009 21:54:45

gattosilvestro
Moderator
Registrato: 20-05-2008
Messaggi: 442

Re: Problemi con effetti visivi

Io ho provato ma non ho nessuno di questi problemi.
Che scheda video hai? Posta il risultato del comando "lspci | grep VGA".


ASUS P5K-VM | INTEL CORE 2 DUO E6300 | MAXTOR SMT3160812AS, MAXTOR3320820AS | 2 x CORSAIR VS1GB667D2 | SONY AWG170AB2 DVD+-RW DL

Non in linea

 

#3 03-05-2009 23:36:37

Threepwood
Utente
Registrato: 01-07-2008
Messaggi: 44

Re: Problemi con effetti visivi

01:00.0 VGA compatible controller: nVidia Corporation D9M-20 [GeForce 9400 GT] (rev a1)
Questo è il risultato

Non in linea

 

#4 04-05-2009 21:59:58

gattosilvestro
Moderator
Registrato: 20-05-2008
Messaggi: 442

Re: Problemi con effetti visivi

Ciao Threep,
ecco il seguito della nostra conversazione telefonica.
Mentre tu ti divertivi col calcio balilla (sicuramente tu sei uno che rulla, visto come fai il cecchino a openarena wink ), ho provato ad installare i driver nvidia 180.51 seguendo questa guida, è fatta per debian ma vale anche per Ubuntu.

Anche io al riavvio mi sono trovato il messaggio di errore dell'X server:

Codice:

(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module! Please ensure
(EE) NVIDIA(0):     that there is a supported NVIDIA GPU in this system, and
(EE) NVIDIA(0):     that the NVIDIA device files have been created properly. 
(EE) NVIDIA(0):     Please consult the NVIDIA README for details.

Per ripristinare lo stato precedente ho riavviato in "recovery mode" ed ho selezionato "xfix   Try to auto repair graphic problems".

Provo ad approfondire...


ASUS P5K-VM | INTEL CORE 2 DUO E6300 | MAXTOR SMT3160812AS, MAXTOR3320820AS | 2 x CORSAIR VS1GB667D2 | SONY AWG170AB2 DVD+-RW DL

Non in linea

 

#5 04-05-2009 22:54:39

gattosilvestro
Moderator
Registrato: 20-05-2008
Messaggi: 442

Re: Problemi con effetti visivi

Sembra che il driver 180.51 vanno in conflitto con quelli installati tramite Sistema -> Amministrazione -> Driver Hardware.
Ho provato a reinstallare Ubuntu 9.04 e ad installare direttamente il driver nvidia 180.51 ed ha funzionato correttamente.

I passi da seguire per installare il driver 180.51 sono questi:

Dai il seguente comando per installare i pacchetti necessari:

Codice:

sudo apt-get install build-essential linux-headers-$(uname -r)

Per chiudere il server X dai il seguente comando (togli l'underscore in e_tc):

Codice:

sudo /e_tc/init.d/gdm stop

Spostati nella cartella dove hai scaricato il pacchetto di installazione dei driver nvidia e dai il seguente comando:

Codice:

sudo sh ./NVIDIA-Linux-x86-180.51-pkg1.run

Risopondi in questo modo alle varie domande:
- Accetta la licenza e continua
- Seleziona NO alla domanda di scaricare da nVidia
- Scegli OK per compilare il modulo del kernel
- Scegli OK per eseguire nVidia-xconfig
- Clicca OK per terminare
- Riavvia

Se non vuoi reinstallare Ubuntu 9.04 puoi seguire questa guida per rimuovere i driver nvidia precedentemente installati con il programma "Driver Hardware".


ASUS P5K-VM | INTEL CORE 2 DUO E6300 | MAXTOR SMT3160812AS, MAXTOR3320820AS | 2 x CORSAIR VS1GB667D2 | SONY AWG170AB2 DVD+-RW DL

Non in linea

 

#6 05-05-2009 07:46:07

Threepwood
Utente
Registrato: 01-07-2008
Messaggi: 44

Re: Problemi con effetti visivi

GRANDEEEEEEEEEEEEEEE!!!!
ho reinstallato ubuntu e seguendo la tua guida , ora posso dire di avere i driver 180.51 , purtroppo non è servito a risolvere il mio problema.
Continuerò ad indagare, cmq una guida precisa degna di un GattoSilvestro.

smile smile smile

Non in linea

 

#7 06-05-2009 20:29:47

Threepwood
Utente
Registrato: 01-07-2008
Messaggi: 44

Re: Problemi con effetti visivi

Ciao a tutti, oggi posso confermare, HO GLI EFFETTI GRAFICI ATTIVI SENZA PROBLEMI, un GRAZIE gigantesco al Gatto, il problema si è risolto eliminando tutte le cartelle e i file nascosti.
Grazie ancora smile smile smile

Non in linea

 

Footer forum

Powered by PunBB
© Copyright 2002–2008 PunBB